Betreff: ارتقاء سیستم عامل iLO با PowerShell – DL380 Gen9



بنابراین من توانستم با استفاده از نحو زیر از نسخه 2.55 به نسخه 2.81 بروم:

$Result = Update-HPEiLOFirmware -Connection $connection -Location $FirmwareFile -Confirm:$false

تنها هشدار این است که$FirmwareFile variable باید واجد شرایط باشد، به عنوان مثال ‘C:\temp\ilo4_281.bin’ یا cmdlet خطا می دهد.

من با یک مشکل دیگر روبرو شدم، یعنی یکی از هاست ها در نسخه بسیار قدیمی، v2.18 نشسته است، بنابراین نمی توانم آخرین نسخه را بروم. آیا کسی می‌داند که سفت‌افزار قدیمی‌تر را کجا می‌توان پیدا کرد، زیرا پیوند ارسال شده در بالا فقط به شما امکان می‌دهد جدیدترین آن را دریافت کنید.

 

با تشکر.




منبع: https://community.hpe.com/t5/proliant-servers-ml-dl-sl/upgrading-ilo-firmware-with-powershell-dl380-gen9/m-p/7180342#M180223